Can't get my boarder to show

#1
Did I turn them off somewhere?
I'm pretty sure I botched a setting because selecting to display claims to work, but then my posts still have just the bare zombie.

Account settings, settings, "use avatar borders" is set to Show.

Settings, Border Wardrobe:

In here, on the left, there's the bronze border, level borders shows that too, but the picture above "current level" shows a bare avatar with just the gem.

*points* but there, and in comments, I don't even have the reputation gem showing.

Feel I've got something messed up somewhere?